Amazon Fire HD 8" (2016) 16GB Tablet

The OS on this device actually came out in 2015…Lollipop. Unless an OS upgrade can be made you are buying a dinosaur!

I could use something larger than my 4.5" cell phone for a display on my DJI Spark drone, does anyone know if this model (with the older OS) will run the DJI Go 4 app? (I know I’ll have to do some work to get the Google Play store app installed also) Google Play says 4.1 is required, lolipop should be 5.0 ? (also, 4.4 and later are still officially supported)