Amazon Login Error [Fixed]

Summary: There is currently an issue with Login with Amazon on desktop browsers. We’re looking into it and looping in Amazon’s group as well. Updates will be added to this thread when available.

I’ve browsed the forums (because apparently a lot of people have issues with logging in to Woot with Amazon) and tried everything to no avail. I’ve tried different browsers, incognito, clear cookies, etc. Still, every time I attempt to login with Amazon, I get a redirect error. It doesn’t even give me a chance to enter my info - like there’s a coding error. That’s why I tried Firefox instead of Chrome, still nothing.
The error is essentially telling me the redirect to Amazon is not allowed, but for context, I shop on Amazon a LOT…I’m always logged in and successfully able to link other accounts. The only issue I’ve ever encountered is with Woot.

Looks to be a larger issue. Seeing more reports. We’re waking up our team. Hold tight.

1 Like

Same problem here. It worked in the Woot app, though.


Yeah add me to that same group of people only having issues with woot+amazon. Good thing today isn’t a BoC day or people would really be upset ;-). What’s sad is now I have stuff sitting in my shopping cart feeling lonely.


Developers are looking into it. They’re able to reproduce the error.

Some are noting that they’re able to login/purchase through the Woot! App.

1 Like

Add me to the list -
Feel like I should just buy what I want without my Amazon login, but I want my free shipping :wink:

1 Like


Amazon’s LWA group identified and fixed the issue.

Log in and buy ALL the things!!


So I can login with amazon on the app, but even though I have prime, it still wants to charge me shipping. I then have to go to the computer to complete the purchase so the shipping goes away. Any ideas?

Are there gold buttons asking you to confirm your address & payment?

Once you do that, it will loading and remove the shipping charge.

Thanks I’ll try that next time. In a browser, the shipping charge never shows, so I wasn’t sure if I should confirm payment…

I can’t sign in on Amazon on the Woot app.

Could you be more specific as to what is happening and when?

Also, try closing the app and reopening it.