"Login with Amazon" broken?

So, I’m thinking really hard about that 3D printer, and I see I can get free shipping if I log in with my Amazon account. Except, that doesn’t work. The window pops up, I enter my amazon credentials, and the window goes grey and does nothing more. I even tried logging in to Amazon separately with both my and my wife’s accounts, still no joy. A little help, please?

I had no issues

I’ve been having this issue on and off for months now. All this week it has been broken. So, I finally grabbed the javascript console error message.

Please Woot! Don’t dismiss this. Your token requests are being seen as cross-site-scripting attacks by Chrome and thus being denied. Here’s the error (with token info removed):

oa?appActionToken=&language=en_US&acknowledgementApproved=:265 Uncaught DOMException: Blocked a frame with origin “https://na.account.amazon.com” from accessing a cross-origin frame.
at x (https://na.account.amazon.com/ap/oa?appActionToken=

x @ oa?appActionToken=******
&language=en_US&acknowledgementApproved=:265
setTimeout (async)
x @
… and this repeats, timing out forever.

Hi there. Thank you for the information. I’ve pinged our Dev group and opened a trouble ticket with them. Not sure how fast I’ll hear back but I’ll track it.

@joncarmignani Dev here, can I ask for a few bits of info?

  1. Which version of Chrome do you have?
  2. What’s your operating system and version?
  3. Have you tried a fresh incognito/private window?
  4. Have you connected your Woot and Amazon accounts before (by signing up with Amazon or adding it to an existing Woot account)? (it sounds like you have, but I want to make sure)

You can reply here or private message me if you like. To private message me, click on my name and then click on Message in the box that pops up. To check your PMs, click on your avatar in the upper-right corner of any page and then click on the envelope in the menu that appears.

  1. Chrome Version 78.0.3904.70 (Official Build) (64-bit)
  2. Windows 7 Pro SP1
  3. Incognito acted exactly the same.
  4. I have logged in with my Amazon credentials many times

I’ll answer here in case something comes out of this that could help others.

Thank you! I’ve updated the ticket with that information. We’re pinging Amazon’s services as it looks like it’s on their end.

Any word from Amazon? I’m still seeing the same authentication failure as before.

Not yet. It can take quite a while to hear back on one-off issues. :frowning_face: I’m sorry.

So this is STILL broken. I am trying to get feedback from Amazon but their customer service is not good. Are they unresponsive to their business partners too?

Yeah, it’s very hard to get on the queue with them for single customer issues. :angry:

In the meantime, can you login with Woot and then contact CS to get a refund on your shipping. If you’re ok with doing this, I’ll send them a note so they can put a note on your account.

That doesn’t help with the Prime Only offers but private message me on those and I’ll see what we can work out. To private message me, click on my name and then click on Message in the box that pops up. To check your PMs, click on your avatar in the upper-right corner of any page and then click on the envelope in the menu that appears.

PS: Sending you a private message for more info.

To check your PMs, click on your avatar in the upper-right corner of any page and then click on the envelope in the menu that appears.

I’ve had the same issue for months, only with firefox. oddly enough my Chrome works which is what I have to resort to. I’d use the app, but I usually can’t find what I’m looking for on it.

Update:
This seems to work in Firefox now but still not in Chrome.

“… and this repeats, timing out forever.”

For what it’s worth, I can “Login with Amazon” using Firefox rev 48.0.2 on MacOS 10.7.5.
Attempting to “Login with Amazon” using Firefox rev 70.0, on MacOS 10.10.6, never completes.

I can login to Woot using my Amazon info on Edge but not Chrome. Seeing the other comments here leads me to believe this is not a single customer or one-off issue. Besides, “Login with Amazon” broken has been viewed 890 times - maybe a lot of people having this same problem? I’ll be grateful when this gets resolved.

Hi there. That’s unusually. Usually Edge has the problem.

Here’s a few things to try:

  • Log out of Woot and log in using the Login with Amazon button
  • On the checkout page, check “use this address”
  • If you are using Microsoft Edge, switch to Chrome or FireFox
  • Clear cookies for Amazon & Woot
  • Allow cookies from Amazon & Woot
  • Allow pop-ups; turn off pop-up blockers
  • Log out and back in on Amazon, especially if you’ve changed anything there (e.g. cards, email, etc.)
  • Try an incognito or private mode in your browser

If those don’t work, let me know the following information:

  • App or Desktop?
  • Device & OS/Version
  • Browser & version
  • Exactly what is happening and when it happens.