TCL 50" 4K UHD Roku Smart LED TV

FYI, my daughter has one of these TVs (smaller size, but same brains). These things will KILL your 5GHz band on your Wi-Fi. The Roku 3 platform that this is built on has implemented Wi-Fi direct which is intended to support short range device-to-device connections. Since the TV only has one 5GHz radio, it broadcasts the Wi-Fi direct on the same channel as the network it is connected to. And since the remote, by default, connects to the TV via the Wi-Fi direct, it will overpower the Wi-Fi direct to ensure that the remote always works…which will prevent any other device from being able to use the 5GHz band. I found this as I was trying to set up my Google Wi-Fi mesh.

If you find that this is a problem for you, you might have luck with the steps outlined here: http://www.netconsonance.com/2016/06/how-to-prevent-roku-wifi-direct-breaking-5ghz/

In my case, these steps didn’t completely fix my problem. I had to disable several other features of the TV, and even that was only spotty improvement. If I unplug the TV, my network is great…if it’s on, my mesh has issues. So, good luck.

The specs on Woot say this has a refresh rate of 60Hz, but according to the TCL site it lists it as 120Hz. What gives? This is pretty important.

http://www.tclusa.com/currentmodels/50up120/

60Hz may be a dealbreaker :frowning:

Information on the internet about this is very conflicting from site to site and even on the TCL site. For example, download the Spec sheet from the link you gave. It says 60Hz.

We’re playing it safe and saying that it’s 60Hz native resolution and 120Hz Effective.