"update browser" prompt within Android app [RESOLVED]

I’m getting an issue where the Woot! app thinks my browser is too old. When I go to forums I get a message at the top of the screen and some minimal forum stats but none of the forums pages work:

I have done the following to try to troubleshoot:

  • Updated chrome to current version
  • Followed the instructions to verify current browser version as linked in the message
  • Deleted Woot! app data
  • Restarted phone
  • Updated Woot!

None of this solved the issue. What’s going on in the back end here? Can anyone help?

Pixel XL
Update version v322

1 Like


1 Like

Hi there.

What version of Chrome/Android?
What browser/version

Also, could you go to meta.discourse.org and see if you get the same error?

1 Like

I do not see the error at the link in chrome.

Android version 10
Chrome version 99.0.4844.73

As for browser version - do you mean something different than chrome version?

What browser then?

Also, you’re saying that the discourse link did work for you? Would you mind downloading & trying the Discourse app?

1 Like

Yes, no issues observed in the discord link via chrome. I use chrome exclusively on this device so “browser” and “chrome” are synonymous for me, but I was thrown off when you asked specifically for versions of chrome and browser - browser is chrome.

I’m replying here via chrome on the pixel XL that was having problems with app forums - no issues with the site when accessed via chrome, but forums show the “browser too old” message when I try to view within the app.


1 Like

The post above was made on a Google Pixel with Android 10 and the updated woot app. I’m not getting any error about the browser.

Could you look to see if you have any add ones that might be conflicting.

1 Like

Joel Berry GIF by BabylonBee

1 Like

Lol. Had to switch to my iPad because the internet went out. I have fat fingers.


Just for my own curiosity, could there be a parallel with this and Chrome’s latest security bug?

I’m an idiot, the bug’s on computer only.

1 Like

Looking into how to see/disable extensions… After I updated it’s not where it used to be.

I hadn’t heard about a new security bug.

So what’s going on here is probably that you have an out of date version of the Android System Webview component. You should be able to update it by going to that link or searching for it in the Play Store.

I pulled my Pixel XL out of storage and was able to reproduce this exact problem. Once I updated the webview component, it began to work normally.




Yes, that did the trick! Thank you @gottaturnupthesound and @ThunderThighs! Now I can forum all the things!


Also, I chuckled when I read this. I’ve considered shelving this phone many times - it’s getting a little slower and might need a battery soon, but otherwise solid. Google’s gonna regret promising me a lifetime of free full-resolution photo backup.

I like to think I’m on an ever-shrinking list at Google. Someday, the CEO is going to call me up and try to get me to switch. I will be belligerent, dramatic music will play, and a thriller plot will emerge.

I have a drawer full of old phones going back over a decade. It’s 50% that I’m a mobile developer and 50% that I have a problem.


I’d love to see an itemized picture your collection.

I find the phone history of some people to be interesting.

1 Like

Maybe I’ll do a thread a little later

1 Like

name that phone.

1 Like