Why do you have to make "log in with amazon" so complicated?

I just want to use chrome to log in to woot with my amazon account.
When I click on the yellow “log in with amazon” button nothing happens - absolutely nothing.
I have turned off all my extensions, popup blocker, privacy badger, ghostery, AdBlock etc…

If I try FireFox, when I click on the yellow “log in with amazon” button a popup window appears with an incredible long URL. If I paste this URL in chrome, the amazon.com sign in page shows up with my email and password already populated. If I click on the yellow “sign in to our secure server” button (still with chrome) it takes me here:
https://na.account.amazon.com/ap/oa?arb=BunchOfNumbers but the page is blank - Oh, it has a bunch of java script stuff in the source but the page is totally blank and I never get logged in.

Why is this so overtly complicated? My woot and amazon accounts are the same (my email address).
And no, I’m not going to clear my browser’s cache and/or temporary internet files as this will clear out all my synced chrome browsers on all my devices.

Try an incognito window in Chrome. That will avoid any issues that your cache might be causing.

Hi there. Something is definitely going on that stopping the login screen from behaving correctly. The incognito window is a very good suggestion.

Can you try it on a different device. That’ll take out all the things that could be blocking it.

Hi,
When you click on the “yellow log in with amazon” button, do you notice a new chrome icon show up on the taskbar at all? Also, do you have dual monitors by any chance? (I am a little embarassed to admit this, but once I had an issue with a pop ip not working, and realized 2 days later that it was showing up on the other monitor…)

Ha!

1 Like

I’m used to constantly having to log off and log on in order to make a purchase with my Amazon account, but since the latest Android update I’ve been having some new issues. Once a day it’s been making me verify my account via text (I don’t have 2step set up on Amazon solely because of the pain it is for woot). Also, in addition to typing in my password every time i log on i have to fill out a captcha (sp?) as well. It usually takes 2 or 3 attempts to get it right, and, well, we all know how fast a BoC goes. Any updates in the works?

Hi there. Could you try removing the app and reinstalling it? Also remove any cookies for Woot/Amazon and clear the cache.

Let me know what that does.

That seemed to fix it. Thanks now I feel kinda dumb lol. But happy I’ll get to be disappointed so much quicker now. My niece will be very happy, I think shes kinda addicted to opening my BoCs.

2 Likes

YAY! Glad that worked.

(whew)

1 Like

This solution did not work in latest version of Firefox.
Disabled pop up blocker as well.
Amazon log in screen not showing up.

Hi there.

Here’s a few things to try:

  • Log out of Woot and log in using the Login with Amazon button
  • If you are using Microsoft Edge, switch to Chrome or FireFox
  • Clear cookies for Amazon & Woot
  • Allow cookies from Amazon & Woot
  • Allow pop-ups; turn off pop-up blockers
  • Log out and back in on Amazon, especially if you’ve changed anything there (e.g. cards, email, etc.)
  • Try an incognito or private mode in your browser

If those don’t work, let me know the following information:

  • App or Desktop?
  • Device & OS/Version
  • Browser & version
  • Exactly what is happening and when it happens.

I’m having the same login issues on Firefox… tried all the above fixes… at least the Woot app works…

Does it work with Chrome? Or on a different computer?

I have done all the requested steps but still no luck in Firefox.
Win 10 desktop with Firefox 69.0.1
nothing happens at all when I click on the Amazon button

Works in Chrome no problem, but that is not my preferred/regular browser due to its known privacy and security issues.

Ok, since it works in Chrome, we know it’s an issue with FF.

What I’ve done in the past to resolve things like this is to disable ALL the extensions and add-ons in FF.
Then add them back one at a time until you find the culprit.

I’m betting this will help you figure it out.

It is the Duck Duck Go Privacy Essentials extension.
Appears to be a privacy leak in the handoff between Woot and Amazon site

2 Likes

Privacy extensions are great but don’t handle well when two companies are involved in a transaction. Because we have two entities, Amazon and Woot, some privacy extensions think Amazon is a leaked to third party even though it’s just a delegation of authorization (and there’s no hope for them ever to programmatically know we’re the same company!). So yeah, that’s an annoying funkiness we have to deal with.

1 Like

Yep. I believe that’s a good analysis.

Thank you for the update. I get what your saying about the hand-off. However, I am fairly certain there is a way programmatically to make it work without having to even triggering a faux case of a data/privacy concern as the issue is usually around some cookie or tracker. Hopefully Woot & Amazon can improve the process in the near future.