Brother MFC-L2705DW All-in-One Laser Printer

Brother MFC-L2705DW All-in-One Laser Printer
Price: $109.99
Shipping Options:: $5 Standard OR $10 Two-Day OR $20 One-Day
Shipping Estimates: Ships in 3-5 Business Days. (Monday, Feb 20 to Thursday, Feb 23) + transit
Condition: Factory Reconditioned

[http://www.wootstalker.com/images/buy.png

Buy It](http://computers.woot.com/offers/brother-mfc-l2705dw-all-in-one-laser-printer) [http://www.wootstalker.com/images/amazon.png

Search Amazon](http://www.amazon.com/s/?field-keywords=Brother MFC-L2705DW All-in-One Laser Printer) [http://www.wootstalker.com/images/google.png

Search Google](https://www.google.com/search?hl=en&tbm=shop&q=Brother MFC-L2705DW All-in-One Laser Printer)

Is this a MFC-2705DW or a MFC-2700DW as in the description?

Approximately how many pages can you get from the included “starter toner”?

I don’t see a reference to 2700?

Googling MFC-2700DW vs MFC-2705DW got this. http://printers.specout.com/compare/1361-1918/Brother-MFC-L2700DW-vs-Brother-MFC-L2705DW

In a nut shell. Looks like the 05 is a “business” machine that costs more (on amazon) then it’s “home” version but not if you look at the MSRP. Specs are pretty much the same but the 05 is a little faster and IMO since I’m around all kids of printers at work, this is a higher volume printer so it should last longer. But on the other hand, the HOME printer shows it will handle different paper sizes that the office version doesn’t. Hope that helps. Looks like a decent machine if you are in the market for a MFC type device.

Approximately 700 pages according to the Brother Specifications.

http://www.brother-usa.com/MFC/ModelDetail/4/MFCL2705DW/spec

This is what the vendor said as well.

I purchased the Brother MFC-7860DW a while ago (looks just like this one) and I have never been able to make it work with Windows 10. It worked fine with Windows 7.

I’ve had the MFC-2700DW for about a year and it works great with Windows 10. Not only printing but the frequently troublesome “Scan to PC” feature works well. Very happy with it.

Did you try downloading the driver from the Brother site?

Yes, I have gone to the Brother site, downloaded their ‘driver removal tool’ program and used their current drivers (another small program), but that did not work. I have also tried manually uninstalling the drivers (using Brother’s step by step process, a confusing long one) and doing the Windows drivers update process (these drivers are NOT on the basic list), but that did not work. I have tried these two methods about 10x each.

I probably have hooked up over a hundred printers (lots of them at work for others), and never had a problem like this one.

Thanks for the suggestion though.

Finally figured it out, the printer needed a firmware update. They do not tell you this, and I did not think of it for a while. Everything just states you need a driver update. It works now.