Google Pixel 4 (Factory Unlocked) (NEW)


Google Pixel 4 (Factory Unlocked) (NEW)

I spent a day trying to get it to work right with verizon and a range extender (that works fine with other LTE phones). it included a 45 minute drive to a verizon store, an hour and change there, that was after using the chat feature on the website, the video chat feature, and also calling tech support. the conclusion before the store was I needed a newer sim card. even with the new sim card mobile voice network was stuck on CDMA and would not do LTE.

And you set the APN to your network?

If you don’t figure it out and want to return it, reach out to Woot! Customer Service.

From a browser, use the Woot! Customer Service form.

In the Woot! App, choose Account from the bottom navigation and then Support.

Note: Woot! Customer Service replies go to the email address on your Woot! account, not your Amazon login email if used/different.

1 Like

Yes APN is set on VZWINTERNET from the sim, everything is set. New Verizon Sim.
Data works fine over LTE, voice does not. Voice is stuck on CDMA 1x.
Under Sim status it shows
Network: Verizon
Number - my number
Mobile Network State: connected
Service State: In service
Good signal strength
roaming - not roaming
Mobile voice network - stuck on CDMA-1xRTT
Mobile date network - either LTE or IWLAN depending on where I am.
ICCID - the ID number
EID - the ID number

I am going to try reaching out to verizon again in a day or two, but then if nothing gets fixed I will need to return it.

three more hours on the phone with Verizon today.
tier 2 couldn’t get it working.
Two open tickets into other groups, could be up to 7 days before I know more.

2 more hours with Verizon today…seems for whatever reason advanced / hd calling is not an option with this phone nor are the settings even there to turn on. I have emailed customer service to return this phone.

Sorry for the problems and time you spent. I found this. Not sure it applies though.

https://www.verizon.com/support/knowledge-base-228769/

1 Like

that and the other advanced calling switch in the network menu aren’t there…

That is weird. Well, CS will help you with the return. Again, sorry for the hassle.

2 Likes

I can’t explain it…I flashed the android 11 firmware on the phone, first to a custom rom, still no luck. reflashed to original android 10 stock rom and then tried a different sim card from my friends phone in the phone…and the missing menus were there. flashed to latest rom, menus were still there…

I tried my sim card in my phone, the menus were still there. I can’t explain it…but after a massive 60 hour quest it does seem to be working!

1 Like

Surprised to still see these in stock, given their overall positive reviews. Still on the fence myself about buying one (I’m still using my ancient Pixel XL), or waiting for the upcoming Pixel 6. My only real concern is the tiny battery. Does anyone have one of these that would be willing to verify how the battery holds up under frequent use? I would trust a Wooter over many other sources :wink:

I have not tried it personally but people I trust said software updates really help the battery situation long after it’s release.

I’ve been waiting to see if scratched and dented ones won’t become available and I might try it one out as well.

1 Like